PDFs generating with watermark
Incident Report for Uptick
Postmortem

On March 1st, at 11am, certificates for out PDF generation service, PrinceXML, expired, resulting in all subsequent PDFs generating with a watermark in the upper right corner.

At 12:46pm, we rerouted PDF generation traffic to a failover service, to allow time for updating these certificates.

At 1:20pm, the primary service was brought back online, fully functional.

Overall, there was a 1 hour and 46 minute window, during which PDFs would have been generating with a watermark.

We apologise sincerely for this disappointment and will be immediately taking measures to remove the possibility of this occurring again in future through a series of early warning checks and alerts.

Posted Mar 01, 2022 - 17:01 AEDT

Resolved
This incident has been resolved.
Posted Mar 01, 2022 - 13:37 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2022 - 12:48 AEDT
Investigating
We've had some reports of PDFs generating with a watermark in the top right corner this morning.
We're looking into the issue presently and will provide an update when it's been addressed.
Posted Mar 01, 2022 - 12:38 AEDT
This incident affected: Uptick Web.