Quickbooks partial outage
Incident Report for Uptick
Postmortem

Between May11th and May 22nd, all interactions with Uptick’s Quickbooks integration had a high likelihood of failure, displaying a “Name or service not known” error. Users needed to repeatedly retry certain actions until their requests got through to Quickbooks.

The root cause of the error was related to DNS resolution. Quickbooks had remapped some IP addresses, which subsequently failed to propagate through to our servers. This remapping and propagation is standard procedure that generally resolves with little to no downtime. We’re unsure as to how Quickbooks rolled it out in this instance that caused propagation to fail outright.

To rectify the issue, we ended up swapping to a different DNS server, which had been propagated to successfully. We’ll continue using this DNS server moving forward.

We appreciate this outage took almost two weeks to resolve, which is far beyond our general response time for issues of a similar severity. Thank you to all affected customers for remaining patient as we worked to find an appropriate workaround.

Posted May 23, 2023 - 18:11 AEST

Resolved
Interactions with the Quickbooks integration would intermittently fail, requiring repeated retries to get through.
Posted May 11, 2023 - 14:25 AEST