Emails landing in Microsoft Outlook spam
Incident Report for Uptick
Postmortem

Across the last few of months (approx August - November), with varying degrees of severity during this timeframe, emails sent by Uptick on behalf of our customers may have been incorrectly flagged as spam by Microsoft Office 365 and Microsoft Outlook/Hotmail.

Due to the nature and frequency of Uptick’s emails (dispatching, quoting, etc), there were unfortunately some reasonable grounds for AI-based spam evaluation filters to get confused here and falsely report Uptick’s correspondence as spam.

Beyond instructing customers to mark Uptick’s email address as a trusted sender, there was little we could directly change here to turn this around.

Over the last few months, Uptick has been working closely with Microsoft engineers to get the spam evaluation algorithms corrected. We believe the issue is now fixed, however due to limited transparency of what goes under the hood, we are continuing to monitor carefully.

To those affected, we apologise sincerely for how long this issue dragged out; we now have measures (and Microsoft contacts) in place, that’ll allow us to jump to action much faster if this reoccurs in future.

In addition, we’re presently rolling out a change to our sender address, which we expect to assist in reducing issues of this nature in future. Stay tuned for announcements about this very soon!

If you have any further questions, please don’t hesitate to reach out to our support team.

Cheers,

Posted Nov 17, 2023 - 15:19 AEDT

Resolved
This issue is now resolved.
Posted Nov 17, 2023 - 15:17 AEDT