Major service outage
Incident Report for Uptick
Postmortem

To ensure the Uptick experience is always smooth, we’re constantly working behind the scenes on improving the stability and performance of our systems. On Friday 26th of March at 3pm, during a scheduled maintenance window, we incorrectly blocked public access to a large portion of customer servers. This resulted in a major service outage for many customers, ranging from 8 to 50 minutes.

Initial downtime started at 3:34pm (GMT+11). A solution was identified and began roll out at 3:40pm, with most of our customers on enterprise or SLA plans back online 6 minutes later (3:46pm). Full operation was restored across all customers by 4:20pm.

The scheduled maintenance window was to work on legacy infrastructure that was being gradually decommissioned, and was not expected to have any impact on production servers.

Uptick knows the cost to your business of any downtime event or disruption of service, and this is something we take extremely seriously. Prior to this incident our availability over the past 12 months was 99.98%, which translates roughly to 9 minutes of downtime per month including planned maintenance (which happens outside of business hours).

We’re deeply apologetic for any business interruption this has caused and we have made appropriate changes to our processes to minimise the risk of incidents like this happening in the future.

Posted Mar 29, 2021 - 16:24 AEDT

Resolved
All systems are once again operational.

We'll put up a postmortem shortly, for those that are interested in the whys and hows.

Have a good weekend!
Posted Mar 26, 2021 - 16:24 AEDT
Monitoring
We are largely back up, just putting out some remaining spot fires now.
Thanks for your patience!
Posted Mar 26, 2021 - 16:10 AEDT
Identified
We're currently experiencing a major service outage across most of our customers.
We expect to be back up and running within the next hour.

We'll keep you updated.
Posted Mar 26, 2021 - 15:41 AEDT
This incident affected: Uptick Web, Uptick Mobile App, and Uptick Customer Portal.