MYOB Integrations disconnected
Incident Report for Uptick
Postmortem

On Tuesday Apr 18th, we experienced an outage of our MYOB AccountRight/Essentials/Business integrations, for roughly 2 hours.

The resolution required all customers to reconnect their MYOB accounts to Uptick to continue using the integration.

This turned out to be, embarrassingly, the result of our MYOB Developer Partner account being deleted due to perceived inactivity by MYOB. We’d received a brief heads up about it at the end of last year, but had managed to miss this crucial email over the end of year period.

Moving forward, we’ll be putting measures in place to ensure this kind of communication isn’t again neglected.

We apologise again for the disruption!

Posted Apr 18, 2023 - 14:27 AEST

Resolved
Incident resolved. We'll follow up with postmortem soon.
Posted Apr 18, 2023 - 10:33 AEST
Monitoring
Good morning!

We had a surprise incident this morning, where our accounting integration with MYOB (Business/Essentials/AccountRight) began failing.
Users would've been seeing an error along the lines of "DeveloperInactive: API key is missing or inactive".

We're still reviewing how the issue occurred, however are glad to announce that the fix is out already.

Regrettably, we've needed to rotate our API keys to offer a resolution. This means that if you're presently using a MYOB Integration with Uptick, you'll need to go into the Uptick Control Panel -> Accounting -> hit "Connect an organisation", and follow the prompts to reconnect your MYOB instance to Uptick.

Until you do so, you will be seeing this error: "ImproperlyConfigured: MYOB authorisation failure - This connection was configured with a different consumer key."

We're sorry for the morning disruption, and will share more of an update when know more.

Regards,
Uptick Team
Posted Apr 18, 2023 - 08:41 AEST
This incident affected: Uptick Web and Accounting Integrations (MYOB Business - Accounting API).