Website styling issues
Incident Report for Uptick
Postmortem

On Wednesday 22nd April, 2020 we experienced some intermittent styling issues which impacted random office users, off and on, and caused either strangely styled pages or blank pages.

The concern lasted approximately 5 hours, with a potential ‘fix’ within the hour to those experiencing the problem earlier on. The fix, which was a hard refresh of the user’s browser, seemed to solve 90% of our user’s problems, however, there was still no definite understanding of what was causing the problem.

The issue was caused by AWS’s Melbourne CloudFront service that deliver our static files, despite nothing being posted on their status page. After a day's back and forth with AWS support, they finally admitted to and fixed a fault on their end.

We will continue to use Amazon Web Services, and further take advantage of their premium AWS support package.

Posted Apr 23, 2020 - 17:05 AEST

Resolved
This incident has been resolved by Amazon and we can no longer replicate.
Posted Apr 22, 2020 - 16:31 AEST
Monitoring
We believe our customers are not experiencing problems anymore, however, we are still monitoring the situation. Please reach out if you are experiencing problems and haven't been in contact yet.
Posted Apr 22, 2020 - 14:42 AEST
Update
We have found a solution for some users still experiencing the problem by doing a HARD refresh of your page. Together click command+shift+r for MAC users and ctrl+shift+r for Windows users.

We are continuing to investigate the issue with Amazon.
Posted Apr 22, 2020 - 12:19 AEST
Update
We are continuing to investigate - it still seems to be a problem with Amazon serving Uptick static content.
Posted Apr 22, 2020 - 10:03 AEST
Investigating
We are currently experiencing problems with Amazon serving static content, if a page appears without styling, you may need to refresh your page.
Posted Apr 22, 2020 - 08:59 AEST
This incident affected: Uptick Web.