Workforce Server Instability
Incident Report for Uptick
Postmortem

The Uptick Workforce product suffered a period of instability on Friday July 15th, after the July release got erroneously partially pushed out to customers ahead of schedule, due to a bug in our deployment scripts. The incident was identified in the early morning, and resolved by midday.

Impact to most customers was minor, manifesting as visual glitches on a select few pages.

We apologise for any interruption this may have caused, and have already put measures in place to ensure it doesn’t repeat.

Posted Jul 18, 2022 - 13:30 AEST

Resolved
Premature deployment of July release.
Posted Jul 15, 2022 - 12:00 AEST